Can't get RTSP streaming to work with b0241 arducam IMX477 HQ cam

Can’t get RTSP streaming to work with b0241-arducam-imx477-hq-camera-6 on Pi Zero 2W running Raspbian Bullseye

Recording the video to file works fine:
libcamera-vid -t 0 -n --width=1920 --height=1080 --framerate 30 -o /home/pi/video.h264

but when I redirect the video to cvlc for RTSP streaming…
libcamera-vid -t 0 -n --width=1920 --height=1080 --framerate 30 -o - | cvlc -v stream:///dev/stdin --sout ‘#rtp{sdp=rtsp://:8554/stream1}’ :demux=h264 --h264-fps=30

VLC media player 3.0.16 Vetinari (revision 3.0.13-8-g41878ff4f2)
[22:17:29.917613084] [130448]  INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3424-e68e0f1e
[22:17:29.963106365] [130452]  WARN CameraSensorProperties camera_sensor_properties.cpp:141 No static properties available for 'imx477'
[22:17:29.963216677] [130452]  WARN CameraSensorProperties camera_sensor_properties.cpp:143 Please consider updating the camera sensor properties database
[22:17:29.963277875] [130452] ERROR CameraSensor camera_sensor.cpp:551 'imx477 10-001a': Camera sensor does not support test pattern modes.
[22:17:30.017706730] [130452]  INFO RPI raspberrypi.cpp:1317 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media3 and ISP device /dev/media0
[22:17:30.019365584] [130448]  INFO Camera camera.cpp:1028 configuring streams: (0) 1920x1080-YUV420
[22:17:30.020047615] [130452]  INFO RPI raspberrypi.cpp:747 Sensor: /base/soc/i2c0mux/[email protected]/[email protected] - Selected sensor format: 2028x1080-SBGGR12_1X12 - Selected unicam format: 2028x1080-pBCC
[22:17:30.090868240] [130458]  INFO IPARPI raspberrypi.cpp:631 Request ctrl: Saturation = 1.000000
[22:17:30.091354698] [130458]  INFO IPARPI raspberrypi.cpp:631 Request ctrl: Contrast = 1.000000
[22:17:30.091441052] [130458]  INFO IPARPI raspberrypi.cpp:631 Request ctrl: Brightness = 0.000000
[22:17:30.091499698] [130458]  INFO IPARPI raspberrypi.cpp:631 Request ctrl: AwbMode = 0
[22:17:30.091556261] [130458]  INFO IPARPI raspberrypi.cpp:631 Request ctrl: Sharpness = 1.000000
[22:17:30.092161886] [130458]  INFO IPARPI raspberrypi.cpp:631 Request ctrl: ExposureValue = 0.000000
[22:17:30.092907198] [130458]  INFO IPARPI raspberrypi.cpp:631 Request ctrl: AeExposureMode = 0
[22:17:30.093687823] [130458]  INFO IPARPI raspberrypi.cpp:631 Request ctrl: FrameDurationLimits = [ 33333, 33333 ]
[22:17:30.094235480] [130458]  INFO IPARPI raspberrypi.cpp:631 Request ctrl: AeMeteringMode = 0
[22:17:30.094791886] [130458]  INFO IPARPI raspberrypi.cpp:631 Request ctrl: NoiseReductionMode = 1
[000000556a652820] vlcpulse audio output error: PulseAudio server connection failure: Connection refused
[000000556a69e5d0] dbus interface error: Failed to connect to the D-Bus session daemon: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
[000000556a69e5d0] main interface error: no suitable interface module
[000000556a57e5c0] main libvlc error: interface "dbus,none" initialization failed
[000000556a657af0] main interface error: no suitable interface module
[000000556a57e5c0] main libvlc error: interface "globalhotkeys,none" initialization failed
[000000556a657af0] dummy interface: using the dummy interface module...
[0000007f80005060] main stream error: unknown query 0x30e in demux_vaControlHelper

… I can’t play RTSP stream using ffmplay (or vlc):
ffplay rtsp://localhost:8554/stream1 -vf “setpts=N/30” -fflags nobuffer -flags low_delay -framedrop

ffplay version 4.2.4-1ubuntu0.1 Copyright (c) 2003-2020 the FFmpeg developers
  built with gcc 9 (Ubuntu 9.3.0-10ubuntu2)
  configuration: --prefix=/usr --extra-version=1ubuntu0.1 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --arch=amd64 --enable-gpl --disable-stripping --enable-avresample --disable-filter=resample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libcodec2 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libjack --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librsvg --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-lv2 --enable-omx --enable-openal --enable-opencl --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-nvenc --enable-chromaprint --enable-frei0r --enable-libx264 --enable-shared
  libavutil      56. 31.100 / 56. 31.100
  libavcodec     58. 54.100 / 58. 54.100
  libavformat    58. 29.100 / 58. 29.100
  libavdevice    58.  8.100 / 58.  8.100
  libavfilter     7. 57.100 /  7. 57.100
  libavresample   4.  0.  0 /  4.  0.  0
  libswscale      5.  5.100 /  5.  5.100
  libswresample   3.  5.100 /  3.  5.100
  libpostproc    55.  5.100 / 55.  5.100
[rtsp @ 0x7fdd8c000bc0] UDP timeout, retrying with TCP   0B f=0/0   
[rtsp @ 0x7fdd8c000bc0] method PAUSE failed: 405 Method not allowed 
[rtsp @ 0x7fdd8c000bc0] Could not find codec parameters for stream 0 (Video: h264, none): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, rtsp, from 'rtsp://localhost:8554/stream1':
  Metadata:
    title           : Unnamed
    comment         : N/A
  Duration: N/A, bitrate: N/A
    Stream #0:0: Video: h264, none, 90k tbr, 90k tbn, 180k tbc
[rtsp @ 0x7fdd8c000bc0] UDP timeout, retrying with TCP   0B f=0/0   
[rtsp @ 0x7fdd8c000bc0] method PAUSE failed: 405 Method not allowed 
[rtsp @ 0x7fdd8c000bc0] UDP timeout, retrying with TCP   0B f=0/0   
[rtsp @ 0x7fdd8c000bc0] method PAUSE failed: 405 Method not allowed 
[rtsp @ 0x7fdd8c000bc0] UDP timeout, retrying with TCP   0B f=0/0   
[rtsp @ 0x7fdd8c000bc0] method PAUSE failed: 405 Method not allowed 
[rtsp @ 0x7fdd8c000bc0] UDP timeout, retrying with TCP   0B f=0/0

RTSP streaming with native Raspberry Pi HQ Camera works this way.

So it can be displayed normally using libcamera-still or libcamera-vid? It’s a little weird, in theory only the picture works fine, the encoding of the backend is consistent, we also tested it and it works fine.