Can't get new camera working

1.Which seller did you purchase the product(s) from?
Amazon UK
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Raspberry Pi 4B 2gb
4.Which instruction are you following?
Paper instructions plus
5.Has your product ever worked properly?
No, it’s brand new and not working from the box
6.What problems are you experiencing?
I can’t get the camera to work.
7.What attempts at troubleshooting have you already made?
I’ve plugged it in using the ribbon cable, connected via ssh, run apt-get update and apt-get upgrade, then go into raspi config, enable the camera and reboot it when finished but when i do a vcgencmd get_camera it always returns “detected 0”. My kit came with 2 ribbon cables, so i tried both and it still does it. I have the ribbon with the blue text side at the front going into the camera, and to the right going into the camera port on the Pi.
8.How would you like us to help you?
Suggest how to get the camera to work