Cameras not detected on PI4

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Raspberry PI 4B
4.Which instruction are you following?
5.Has your product ever worked properly?
Never worked
6.What problems are you experiencing?
I followed the instructions to install the driver, but after reboot the /dev/video0 does not exist and I see the following in dmesg output:

[ 31.835886] arducam_vddl: disabling
[ 31.835907] arducam_vdig: disabling
[ 31.835929] arducam_vana: disabling

Here’s what my /boot/config.txt looks like:


NOOBS Auto-generated Settings:


The only problem I can think of is that in the Release/bin I see 5.4.51-v7l+ but my uname -r returns 5.4.72-v7l+ so I created a symbolic link from 5.4.72-v7l+ to 5.4.51-v7l+ and installed the driver this way.

7.What attempts at troubleshooting have you already made?

8.How would you like us to help you?

OK, so it seems like the driver is not compatible with my kernel 5.4.72-v7l+. Is there any chance you guys can release a new build for this kernel version? Or at least provide instructions on how to compile it (since the sources are available on Github)?


I’m on 5.4.83 (the latest official Pi image) and have the same problem.

If would be really good if we could have instructions to build the drivers as this problem is likely to happen a lot.

At the moment I can;t use the camera and will have to look for alternatives.

I’m on the last official release of Raspbian too and it’s still not working.

On the website it said that the product is compatible with the pi-4B, but the Raspbian version required to make it work (9.8 or less) does not work with the pi-4B.

I’m really looking forward to alternatives.

Hello, everyone

We have upgraded our driver package:

By the way, how to compile the kernel driver, see here: