Camera + shield USB 3 not working

1 Where did you get the camera module(s)?
Uctronics for the shield
ThePiHut for the camera module
2 Model number of the product(s).
Camera UC-788 + USB 3.0 shield UC-593 Rev.C
3 What hardware/platform were you working on?
Windows 10 and Ubuntu 22.04 LTS on a laptop Legion 7 Ryzen gen 2
4 Instructions you have followed. (link/manual/etc.)
For windows:

[16:27:34]USB camera init success!
[16:27:46]USB transfer timeout error
[16:27:46]USB transfer timeout error
[16:27:46]USB transfer timeout error

And no image is displayed. We also tried to register manually some values and it seems to work but no stream is displayed again.
For Ubuntu:
We followed the instructions for the installation described here OV2311 optical specification - #8 by enyokhai

But without any success. We constantly recive the error: The error code 65312 (FF24). And after the application freeze.

For both:

We tried with two identical cameras we purchased. Same situation.
8 What help do you need?
Our first objective is to make the camera+shield working on Ubuntu. We would need a hand in understanding the problem we encounter. Many thanks in advance!

An image of the shield:

Many thanks in advance for your help!

We will arrange the test for your situation in the days to come. Please wait for our news.

1 Like