Camarray on RPi 4B: xhci_hcd init fail

1.Which seller did you purchase the product(s) from?

2.The Model number of the product(s) you have purchased?
Four OV9281 Global Shutter Camera Modules and Camarray Camera HAT

3.Which Platform are you using the product(s) on?
Raspberry Pi 4B

4.Which instruction are you following?

5.Has your product ever worked properly?

6.What problems are you experiencing?
Installed latest Raspberry OS and followed the instruction to install Arducam driver.
After reboot, the RPi cannot boot properly. Boot stops at:

xhci_hcd 0000:01:00.0: can't setup: -110
xhci_hcd 0000:01:00.0: init 0000:01:00.0 fail, -110

7.What attempts at troubleshooting have you already made?
Tested different Raspberry OS versions, but the issue seems connected to that the Arducam driver installs a different kernel version?

8.How would you like us to help you?
Work-around or solution.

Tried with a RPi 3B instead, running Raspberry OS and followed this instruction.

Driver installation seems to be fine, but running

arducamstill -t 0

Gives me error message

Hardare version: a02082
Error opening device.
arducamVideoInit failed.
Unable to set format: Bad file descriptor (9).