Camarray – Arducam 1MP (Monochrome) Quadrascopic Camera Bundle Kit stopped working suddenly

I am using a Camarray – Arducam 1MP (Monochrome) Quadrascopic Camera Bundle Kit with a jetson nano 2GB dev kit. I have been using it for a while then suddenly it stopped. The module is detected but when I run the script I get this error log. The green led on the HAT flashes when I power the module but not when I run the python script.
Firmware Version: 3
Sensor ID: 0x9281
Serial Number: 0xADAF455F
select timeout
VIDIOC_DQBUF: Resource temporarily unavailable
Traceback (most recent call last):
File “”, line 115, in
display(cap, arducam_utils, args.fps)
File “”, line 35, in display
frame = resize(frame, 1280.0)
File “”, line 13, in resize
width = frame.shape[1]
AttributeError: ‘NoneType’ object has no attribute ‘shape’

dmesg log
[ 0.212041] DTS File Name: /var/jenkins_home/workspace/n_nano_kernel_l4t-32.6.1-arducam/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t210/batuu/kernel-dts/tegra210-p3448-0003-p3542-0000.dts

[ 0.408347] DTS File Name: /var/jenkins_home/workspace/n_nano_kernel_l4t-32.6.1-arducam/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t210/batuu/kernel-dts/tegra210-p3448-0003-p3542-0000.dts

[ 1.302982] arducam-csi2 6-000c: firmware version: 3

[ 1.303336] arducam-csi2 6-000c: Sensor ID: 0x0000

[ 1.354005] arducam-csi2 6-000c: sensor arducam-csi2 6-000c registered

[ 1.516259] vi subdev arducam-csi2 6-000c bound

I have seen people having the same issue with this module but no feedback regarding the possible origin of the problem.