Camaray HAT module and Syncing HQ cameras

Hi,
I have an RPI Bullseye with a Camarray Hat module to sync 4 HQ cameras together. This is the camera that I have: Raspberry Pi High Quality HQ Camera [12MP] : ID 4561 : $50.00 : Adafruit Industries, Unique & fun DIY electronics and kits.
Unfortunately, libcamera does not preview the cameras and I am not sure what is wrong with it. This is the error that I get when I run the preview command:

libcamera-hello
Preview window unavailable
[0:09:14.082693152] [1894]  INFO Camera camera_manager.cpp:299 libcamera v0.0.2+55-5df5b72c
[0:09:14.127313236] [1895] ERROR V4L2 v4l2_device.cpp:352 'imx477 10-001a': Unable to set controls: Device or resource busy
[0:09:14.153160975] [1895]  INFO RPI raspberrypi.cpp:1425 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media4 and ISP device /dev/media1
[0:09:14.153376749] [1894]  INFO Camera camera.cpp:839 Pipeline handler in use by another process

Would appreciate it if anyone knows how to fix this issue. Please let me know if you need more info.

Thanks

Now, My issue is solved with libcamera and it perfectly works with just one camera. But when I connect the Camarray HAT, it just previews a black solid page. There must be an issue with the Camarray that the cameras do not work. Is there a way to solve this issue or it is a bug in the Camarray module?

Thanks,