B0263 and B0223 at the same time on Jetson Xavier NX

  1. Where did you get the camera module(s)?
    UCTronics

  2. Model number of the product(s)?
    B0263 and B0223

  3. What hardware/platform were you working on?
    Jetson Xavier NX

Hello,

First: I was able to use B0263 stereo module correctly connected to the “CAM0” port on Jetson Xavier NX kit.

Second: I connected B0223 camera to the “CAM1” port and I tried to used both camera at the same time. It worked during some time and after I restart my system.

After Restarting the system, the B0263 stereo module does not provide frames. I am able to get this output:

[email protected]:~$ v4l2-ctl --list-formats-ext
ioctl: VIDIOC_ENUM_FMT
Index : 0
Type : Video Capture
Pixel Format: ‘GREY’
Name : 8-bit Greyscale
Size: Discrete 2560x800

Index       : 1
Type        : Video Capture
Pixel Format: 'Y10 '
Name        : 10-bit Greyscale
	Size: Discrete 2560x800

Index       : 2
Type        : Video Capture
Pixel Format: 'Y16 '
Name        : 16-bit Greyscale
	Size: Discrete 2560x800

But when I use the demo script I get this:

MIPI_Camera/Jetson/Jetvariety/example$ python3 arducam_displayer.py
Firmware Version: 3
Sensor ID: 0x9281
Serial Number: 0xADA4B931
select timeout
VIDIOC_DQBUF: Resource temporarily unavailable
Traceback (most recent call last):
File “arducam_displayer.py”, line 115, in
display(cap, arducam_utils, args.fps)
File “arducam_displayer.py”, line 31, in display
frame = frame.reshape(int(h), int(w))
AttributeError: ‘NoneType’ object has no attribute ‘reshape’

I have verified connections several times, change to other flat cable but the problem persist.

Please help me.

Hi @jeslava
Thank you for the information,
So it can work normally every time, until you restart the system?

I need to confirm some information:

  1. When it is not working, will the green LED on the back of the module flash a few times when running camera commands (only in the first few seconds of executing the command)
  2. Complete dmesg log when the camera is not working