Arducam Stereo Camera Hat cannot be detected

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
Product Code: B0195S8MP
3.Which Platform are you using the product(s) on?
Raspberry Pi 4B
4.Which instruction are you following?
Online Documentation
5.Has your product ever worked properly?
Worked once in the beginning, then never again.
6.What problems are you experiencing?
My RPi does not recognize my camera.

Using vcgencmd get_camera, I get the output of “supported=1 detected=0”

Using ./arducamstill in the MIPI_Camera/RPI folder, I get:
Open camera…

Hardware platform: d03114

init camera status = 4100
When I try raspistill -o Desktop/image.jpg, I get error messages:
Cannot read camera info, keeping the defaults for OV5647
mmal_vc_component_create: failed to create component ‘’ (1:ENOMEM)
mmal_component_create_core: could not create component ' (1)
Failed to create camera component
main: Failed to create camera component
Camera is not detected. Please check carefully the camera module is installed correctly

7.What attempts at troubleshooting have you already made?
I have already ensured my connections are connected correctly and restarted and replugged my RPi and hat multiple times. I have already tried testing the hat with one and both cameras disconnected, and tested the wires given with a multimeter and verified they are conductive. I have also tried testing my RPi camera port by connecting an 8MP camera to it, where it does show an output.
8.How would you like us to help you?
How could I solve this problem of the RPi not recognizing the camera hat, or verify that I would need to request a replacement for the hat?