arducam pullling I2C SDA low permanently

Hey everyone

Ive been trying the get the Arducam 16MP IMX298 Color MIPI Camera Module to work with some I2C controlled LEDS.

Im able to detect the LEDS and controll them perfectly. i2cdetect -y 1 shows 4 addresses that correspond to the 4 LEDS.

Im also able to take pictures with the camera. When plugged in, i2cdetect -y 0 show around 6 addresses that disappear when the camera is unplugged. i2cdetect -y 1 doesnt show any addresses.

The problem is that when both the LEDs and the camera are conntected to the raspberry, the SDA of the I2C channel 1 is pulled low permanantly.

I tried to use a software i2c interface by following the this tutorial:

I still get the same results. everythings fine when either one of the modules are used (LEDs, camera). But i get the same problem when both are plugged in.

Has anyone of you ever encountered this problem?


The Arducam mipi camera is mounted on the i2c0 bus. There is nothing to do with the i2c1.
Please attach me your hardware setup and I will help you check it.
As normal, if you connect the led to the i2c1 and it will not be influenced with the camera.