ArduCAM OV9281 not working on Xavier NX dev. kit

1.Which seller did you purchase the product(s) from?
Not sure. Company purchased it but likely UCTRONICS.
2.The Model number of the product(s) you have purchased?
ArduCAM UC-580 Rev. C and ArduCAM UC-667 Rev. C adapter (programmed for OV9281 at purchase)
3.Which Platform are you using the product(s) on?
Xavier NX dev. kit programmed with JetPack 4.4.1 (downloaded 1/5/2021) straight from SDK Manager.
4.Which instruction are you following?
Automatic driver installation as per https://www.arducam.com/docs/camera-for-jetson-nano/mipi-camera-modules-for-jetson-nano/driver-installation/
5.Has your product ever worked properly?
On a Pi 4, but not the Xavier NX.
6.What problems are you experiencing?
When I run the arducam_display.py example (https://github.com/ArduCAM/MIPI_Camera/tree/master/Jetson/Jetvariety/example) I get a black window. If I try to use V4L2 in C code I also get a black image. When I look at the dmesg log, it says that during boot, arducam-csi2 10-000c registered the sensor and subdev arducam-csi2 10-000c is bound to the tegra194-vi5 15c10000.vi hardware (firmware version 1, sensor ID 0x9281 reported). All looks good until I run the example, at which point it reports:
tegra194-vi5 15c10000.vi: no reply from camera processor
tegra194-vi5 15c10000.vi: uncorr_err: request timed out after 2500 ms
tegra194-vi5 15c10000.vi: err_rec: attempting to reset the capture channel
tegra194-vi5 15c10000.vi: err_rec: successfully reset the capture channel
These four lines then repeat until I stop the example.
7.What attempts at troubleshooting have you already made?
I’ve tried to confirm the connections were properly made between the dev. kit and adapter board, and adapter board and camera. I tried a VC MIPI OV9281 camera (with its own Xavier NX image) and it worked so the MIPI connector works. I’ve also tried an IMX219 (before installing ArduCAM drivers) and that also worked.
8.How would you like us to help you?
I would like to get the camera working on the Xavier NX dev. kit.

Hi @dmadill ,

We are very sorry, but there have been some problems in our system recently, which caused us not to see your reply.
Not sure if your problem has been resolved, here is the response to the problem:

Will it work on the latest system? From the error message, it seems that the camera does not output data. This may be a cable problem.

Best Regards,

Hi @dmadil
how did you solve this problem? I am having the same issue as you described.