Arducam output show black background with white edges for objects?

  1. Where did you get the camera module(s)?
  1. Model number of the product(s)?

Arducam 4K 8MP IMX219 Autofocus USB Camera Module with Metal Case, 1080P Mini UVC USB2.0 Video Webcam with Dual Microphones, 3.3ft/1m Cable for Computer, Laptop, Raspberry Pi, Jetson Nano

  1. What hardware/platform were you working on?

Raspberry Pi 4

  1. Instructions you have followed. (link/manual/etc.)

Online documentation, forum posts.

  1. Problems you were having?

Image appears with a black background and white edges.

  1. The dmesg log from your hardware?

[587557.734473] usb 1-1.3: new high-speed USB device number 5 using xhci_hcd
[587557.873271] usb 1-1.3: New USB device found, idVendor=0c45, idProduct=6366, bcdDevice= 1.00
[587557.873286] usb 1-1.3: New USB device strings: Mfr=2, Product=1, SerialNumber=3
[587557.873296] usb 1-1.3: Product: USB 2.0 Camera
[587557.873305] usb 1-1.3: Manufacturer: Arducam Technology Co., Ltd.
[587557.873314] usb 1-1.3: SerialNumber: SN0001
[587557.899565] input: USB 2.0 Camera: USB Camera as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/1-1.3:1.0/input/input2
[587557.936137] usb 1-1.3: 3:1: cannot get freq at ep 0x84

  1. Troubleshooting attempts you’ve made?
  • Checked parameters with “v4l2-ctl -d /dev/video2 --list-ctrls” and compared against other working camera

  • Tried on another host device

  • Tried other USB ports

  1. What help do you need?

I would appreciate input on how to fix the image output from the camera.