Arducam not being detected in arduino programs on Nano 33 BLE sense

I am not able to get the Mini 2MP plus to work on the Nano 33 BLE sense. I have tried it with the Person_Detection example provided by TensorFlow and the example ArduCAM_Mini_2MP_OV2640_Functions, but neither one of them detect the camera and both give me errors. My wiring is fine as I’ve checked it multiple times from multiple wiring diagrams. I am using pin 7 for the CS as well.

Is there a reason why nothing is working? I changed memorysaving.h to work properly with the Plus.
Any suggestions would be great, thank you.


Please refer to this link:

I have the correct model, and it is wired correctly. It just is not being seen by the arduino. I saw “USB drivers” mentioned somewhere, what is that about?


I think you need to make sure that Nano 33 BLE can download and run the program normally, and then perform the camera test program.

If the camera program is downloaded but it does not work, please send us the debugging information output by the serial port.

Running ArduCAM_Mini_2MP_Plus_functions gives me an error of:
ACK CMD SPI interface Error! END

CS is on pin 7 of the arduino.


I suggest you refer to the connection in this link:

His book is actually the one I’ve been following… I have the latest libraries for everything.

We tried to run it via the arducam host but got this error:

Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index


When you run the example of ArduCAM_Mini_2MP_Plus_functions and SPI error appear, there are three possible reasons:
One is that the SPI connection is incorrect.
The other is that the SPI speed is too fast and the communication fails.
The last one is a problem with the SPI driver itself.
Judging from your description, you seem to have used other people’s examples, and we don’t know whether other people’s examples are inherently problematic.
In view of this, I suggest you run our example with Arduino UNO first to confirm that there is no problem with the camera itself.

What speed should the SPI be at and how would I get a different SPI driver? I do not own an UNO so I can’t really test it there. We have two nano 33 ble senses and two OV2640 2MP plus’s, but neither set ups work. The only pin that I noticed can be in a different spot is CS and I have my CS pin at pin 7 as your program uses pin 7 for it.


Pin7 is not necessarily D7, please make sure that CS is correctly connected to D7!
If the problem persists, please try to change other CS pins. In addition,I recommend that you use the example that comes with the ble library to test whether the SPI is normal.

I meant D7 when I said pin 7. I also tried D9 but that did not work either.


In this case, I can only suspect that there is a problem with the camera or your Nano 33 ble, but I still recommend that you find a UNO to testthe camera. If you can’t confirm, then it is recommended that you contact the sales mailbox for return.

Well we have two nano’s and two OV2640s. However, both do not work.


It is recommended that you contact the sales mailbox for return.