ArduCam Mini 5MP OV5642 - getting it working

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?

3.Which Platform are you using the product(s) on?
Arduino Mega 2560
4.Which instruction are you following?
Paper Instruction and your online documentation and your video tutorial
5.Has your product ever worked properly?
Never worked
6.What problems are you experiencing?

  1. I have a Arducam 5MP Plus OV5642 Mini Module Camera Shield SPI Camera Module for Arduino UNO Mega2560 Board

And I have it connected to my Arduino Mega2560 Board

(I tried connecting it to my Uno to run one of the example sketches but it said the sketch was too big - so I switched to the Mega)

  1. I have wired the camera as per the instructions that came with the camera.

CS - Digital 7
MOSI - Digital 11
MISO - Digital 12
SCK - Digital 13
VCC - 5V

  1. I changed the <memorysaver.h> file to the correct shield

#define OV5642_MINI_5MP_PLUS

and left everything commented out

  1. I am able to load the example ArduCAM_Mini_5MP_OV5642_Plus_Functions onto the Mega without getting any errors

  2. And I made sure that the lens cap is not on


When I access the ArduCam Host App V2, I am not able to get any images from the camera! It says the connection is open but I don’t get any other feedback.

I’m not very good at physical computing and I need some help trying to solve this problem. I don’t know what I’m missing. It’s probably something very small and simple that I have overlooked and I would really appreciate the help.

Please let me know if you need me to post more information.

7.What attempts at troubleshooting have you already made?
See message above
8.How would you like us to help you?
Review my post and see if I have missed anything.


Okay I now get an error message in the ArduCam Host App but I’m not sure how to fix it.

Arducam app pic


First use the example test of arduino uno to make sure there is no problem with the camera.
In addition, the SPI Interface Error in your picture may be caused by incorrect SPI wiring, or the SPI line is too long.