arducam mini-2mp-plus can't run

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
raspberry pi 4B/ Pico/ arduino Uno
4.Which instruction are you following?
video tutorial
5.Has your product ever worked properly?
never worked
6.What problems are you experiencing?
Hi, please help me to run my arducam mini-2MP-Plus. I followed the video tutorials as below, my mini-2MP-Plus arducams just don’t work:



In the (1) video, I followed all the steps and tried lots of times. changed the pico, changed the arducam(I have three), changed the raspberry pi, checked all the wires and hardware, used the compiled uf2 file… after minicom -b 115200 -o -D /dev/ttyACM0, there is SPI bus fail…

so i tried to reach my arducam for just taking photo. I encountered the exactly same problem as other people(I put the link below). However, there are 3 cams and only one Uno… I can’t use the same solution.

please help me and thank you.
7.What attempts at troubleshooting have you already made?
changed hardware, re-install software …
8.How would you like us to help you?
as possible as you can


You don’t seem to find the correct operation tutorial, you can refer to the link below to test.

hi, i will try it later, thanks.

my goal is to try person detection on my pico, how about the video (1). are there any new version or tutorials?

I tried the tutorial you said. there is no different between I tested by uno or by pico. Nothing showed up.

there are missing lots of details, so I refer the hardware wiring here.

i cant get the arducam:


I can’t demo the person detection by pico with arducam:


I’ve successfully tested the ArduCAM 2MP on a Pico using the ArduCAM video Host on a MacOS, so this should be no problem.

One thing I notice is that the Host program you are running has the wrong Baud rate settings: try the 900K settings, since this matches the speed set in the client program that runs on the Pico.

To be precise, it’s the 921600.

The other thing to check is that the COM port is the correct one. You should see some strings coming from the Pico, while you just seem to see strings coming from the Host program itself.

I had to change the COM port to get the correct one.


Please don’t worry, I will try my best to solve the problem for you.

About SPI error,I suspect it is a wiring problem.

Please connect as shown in the figure below to ensure that the connection is normal.

Then use our test file to verify that there is no problem with the hardware. connection.Download test file RPI-Pico-CAM/tflmicro/bin/person_detection_Int8.uf2 file to Pico.

Open RPI-Pico-CAM/tflmicro/person_detection_display/person_detection_Display.pde displays the image,And check the port number.

This is the result I just tested.

hi, I did it again after your replied. Still got the same outcome.

  1. my setting are all same as tutorial: pi4/pico/arducam/TTLtoUSB/jump wire

  2. I tried to use different, but same type, cam/pico/pi4 to test

  3. even checked all wire connection by electric-meter

  4. all baud rate tested, 115200/921600…

  5. download uf2 example. * my pi can’t detect ttyACM0 if I used the uf2 made by myself

all the testing get same result, that is why I am here for help.


Please don’t worry, I will try my best to solve the problem for you.

I see an SPI error displayed on the terminal, please send your connection diagram over, or try to change a few DuPont cables.

Feel free to let me know if you need more help.

as I said, I did the connection lots of times (more than 5 times), and checked all the connection went well.

my external TTLtoUSB and pico microUSB all connected to the raspberry pi 4B. I even changed the raspberry pi4/pico/arducam to try.

I really struggled to find the bug.


I checked your connection and found no problem. You can try to use the Arduino UNO development board to drive the OV2640 camera to see if the camera is malfunctioning. If the camera is not malfunctioning, you can use a multimeter to check if there is any problem with the DuPont thread.

Arduino driver camera link: