Arducam IMX477 UVC Camera Adapter Board Max Exposure time

1.Which seller did you purchase the product(s) from?
The PiHut
2.The Model number of the product(s) you have purchased?
B0278
3.Which Platform are you using the product(s) on?
Linux/Raspbian
4.Which instruction are you following?
Online
5.Has your product ever worked properly?
Yes
6.What problems are you experiencing?
According to v4l2-ctl, the max exposure of the pi imx477 camera attached to the uvc board is limited to 0.5 seconds. This is much less than when the camera is attached to the pi via csi directly.

Is there a way (like a firmware update to the uvc board) to increase the limit of the max exposure? The reason I’m asking is that I’ve been trying to convert the pi hq camera to a guide camera/electronic finder for a telescope project. I’d prefer the convenience of the usb cable to the fragile csi cable if I could make the camera take long exposure with the uvc board.
7.What attempts at troubleshooting have you already made?
N/A
8.How would you like us to help you?
Firmware update

I am also have a low exposure issue using this on the pi hq camera…

I remember reading that the imx477 for the nvidia-jetson had a exposure issue when trying using it on the Pi… possibly the uvc board config is for that modal and not the pi modal when being flashed/assembled in factory… can’t say for sure.

so i ordered a

Arducam for Jetson Nano IMX477 HQ Camera Board with Tripod Mount and C-CS Adapter, 12.3MP Camera Board for Nvidia Jetson Nano/Xavier NX and Raspberry Pi Compute Module

looks very close to the RPI-HQ version

but if you look at this sensor, it has a 22pin connection – not a 15 pin like a PI 4 has for input.In the package contents for the uvc-usb there is a 22pin to 22pin (for the jetson camera)

some “specs” i was reading was there is 2 spi-lanes used in the jetson version- and 1 in the PI-HQ version. so it very much possible that the “bad exposure time” is caused because its reading a black(nothing) from the sensor on that 2nd lane.

2nd theory is that the Chip is not “detecting” if 1 or 2 lane spi sensor. and the board is defective if there is no way to “flash” the uvc-usb board

i will be back in a when i get the sensor and attach it to the board…

Thanks for chipping in.

The max exposure of the RPi HQ camera was curbed at 1 sec after the initial launch. It was then extended to 200 secs following the requests from many users who had been trying to adapt the new camera to their astro or time-elapsed projects.

Maybe you’re right the uvc-usb board is still configured based on the original spec of the RPi HQ camera module.

So i got the camera

 

“Arducam for Jetson Nano IMX477 HQ Camera Board with Tripod Mount and C-CS Adapter, 12.3MP Camera Board for Nvidia Jetson Nano/Xavier NX and Raspberry Pi Compute Module”

 

its produces the same results of exposure. so it defiantly the UVC board

Thanks for confirming this.

Wish Arducam would release a firmware update to remove the exposure cap if possible. As it stands now, the uvc-usb has very little value.

Due to the forum malfunction, I am sorry that we could not reply to your question in time. Has your problem been solved now?

No. Without you guys releasing a new firmware, the problem cannot be solved.

Hi,

Please describe the product you purchased and the platform used, and send an email to [email protected] and we will update the firmware for you.

did someone get a better firmware?
if so please share it

No updated firmware since I sent whatever I wrote in my original post to the support. The problem remains.

Hi,

Our updated firmware optimizes the dimming problem that some users said.
And your need is long exposure, the long exposure function is not available in general UVC cameras. Therefore, if you want to achieve a long exposure, such as 100s or 200s of exposure time, you need to contact the sales mailbox for customization.

Hi,

Thanks for your quick reply. So you’re saying I should forward the message to [email protected]?