Arducam imx477 drivers issue with Jetson nano seeed J1010 when doing memory card expansion camera doesnt work plus card unmouts on drivers installation

  1. Where did you get the camera module(s)?
    UCTRONICS : New Order #1000029680
  2. Model number of the product(s)?
    Arducam 12MP 477P Motorized Focus High Quality Camera for Jetson Nano/Xavier NX and NVIDIA Orin NX/AGX Orin

SKU: B0273
3. What hardware/platform were you working on?
Seeed Studios reComputer J1010 Jetson nano
Jetpack 4.6.3
4. Instructions you have followed. (link/manual/etc.)

  1. Problems you were having?
    The problem i am having is when i do the memory expansion the camera stops working i have two of them attached on the normal emmc boot the cameras work once i do the expansion following the link the camera stops working on reinstalling the driver the nano reboots but the sd card doesn’t mount and the system crashes
    i have tried many times reinstalling and re-enabling the sd card but nothing worked and we are running short on memory on the emmc .

  2. The dmesg log from your hardware?

  3. Troubleshooting attempts you’ve made?
    tried installing drivers before memory expansion ( crashing )
    then after expansion installed drivers (still crashing )
    tried only mounting the rootfs folders like ,/opt ,/usr still after installing the drivers sd card disabled and system crashes

  4. What help do you need?
    is there something in the installation script that disables the sd card from mounting again because without the drivers installed the expansion works fine