Arducam IMX219 not recognized in jetson nano (probe failed)

Hi,

I’m having trouble with having a new IM219 module recognized on my jetson nano with the latests jetpack. I followed documentation on how to setup the drivers available in your github.

it doesn’t list in /dev/video*

I see error messages in dmsg related with arducam-csi2:

[ 1.714554] arducam-csi2: arducam_read: Reading register 0x103 failed
[ 1.721059] arducam-csi2 6-000c: probe failed
[ 1.725467] arducam-csi2 6-000c: Failed to setup board.

any advice of what I can try next?

Thanks

In case it helps:

[email protected]:~$ cat /etc/nv_tegra_release

R32 (release), REVISION: 4.3, GCID: 21589087, BOARD: t210ref, EABI: aarch64, DATE: Fri Jun 26 04:38:25 UTC 2020

[email protected]:~$ uname -a
Linux nano 4.9.140-tegra #2 SMP PREEMPT Mon Jul 13 13:19:50 CST 2020 aarch64 aarch64 aarch64 GNU/Linux

driver I’m using is arducam-nvidia-l4t-kernel_4.9.140-32.4.3-20200716095813_arm64.deb

Hi @luismesas ,

IMX219 does not have Jetvariety board and does not need to install arducam driver, you can directly connect the camera to Jetson Nano and use it.
Before that you need to uninstall the arducam driver using the following command:
sudo dpkg -r arducam-nvidia-l4t-kernel

I don’t know why I thought it was going to be more complicated.

Thanks for your help :slight_smile:

Sorry for your experience, it seems that our description is not detailed enough, we will go through to optimize it.

Hello,

I have Jetson nano B01 with the same system and Ardrucam IMX219-AD (B0189).

I was the same problem as @luismesas, that when I installed driver camera wasn’t recognized in dev/video*. I uninstalled this driver and camera is recognized but doesn’t work. I use command: “gst-launch-1.0 nvarguscamerasrc sensor_id=0 ! nvoverlaysink”, then computer was frozzen and restart. I used image from nvidia and from sdk then error is the same.

What is requirement to run up this camera ?

Hi @mateusz ,

Can you provide terminal output and dmesg log?

Tip: If the system cannot be used after running the camera, you can use the dmesg -w command to view the log in real time, and use the smartphone to take a photo and send it to us after the system crashes.

Hi,

In below link is attachments contain logs:

  • “dmesg_log_after_normal_run_up_with connect_camera.txt” Log ploted after power Nvidia Jetson and wrote dmesg -w in terminal.
  • “Terminal_after_gst_launch_1_0.jpg” This is picture from terminal after wrote command: “gst-launch-1.0 nvarguscamerasrc sensor_id=0 ! nvoverlaysink”. After this step Nvidia was restarted.
  • “dmesg_log_after_gst_launch_1_0_nvarguscamerasrc_sensor_id_0.txt” Log plot after restart Nvidia Jetson because I wrote in terminal “gst-launch-1.0 nvarguscamerasrc sensor_id=0 ! nvoverlaysink”.

Sorry, my link didn’t add to previous post:
https://www.mediafire.com/folder/wte7th4xfe2w4nf,qrsvpztl7r4xwgg,29x60u0h4tx4fsm/shared

Hi @mateusz ,

I didn’t see any error from the log, can you try this gstreamer pipline?

DISPLAY=:0.0 gst-launch-1.0 nvarguscamerasrc sensor_id=0 ! ‘video/x-raw(memory:NVMM),width=3280, height=2464, framerate=21/1, format=NV12’ ! nvvidconv flip-method=0 ! ‘video/x-raw,width=960, height=720’ ! nvvidconv ! nvegltransform ! nveglglessink -e

I connected UART to Nvidia. I tried your command in terminal then popped up window “gst-launch-1.0” and system was frozen. Below is uart log after use this command:

[ 144.342818] Kernel panic - not syncing: Watchdog detected hard LOCKUP on cpu 0
[ 144.350036] CPU: 3 PID: 0 Comm: swapper/3 Tainted: G C 4.9.140-t egra #1
[ 144.357762] Hardware name: NVIDIA Jetson Nano Developer Kit (DT)
[ 144.363754] Call trace:
[ 144.366200] [<ffffff800808bdb8>] dump_backtrace+0x0/0x198
[ 144.371589] [<ffffff800808c37c>] show_stack+0x24/0x30
[ 144.376632] [<ffffff800845c7a0>] dump_stack+0x98/0xc0
[ 144.381673] [<ffffff80081c1438>] panic+0x11c/0x298
[ 144.386455] [<ffffff80081823c4>] watchdog_check_hardlockup_other_cpu+0x11c/0x 120
[ 144.393837] [<ffffff8008181538>] watchdog_timer_fn+0x98/0x2c0
[ 144.399572] [<ffffff80081399e0>] __hrtimer_run_queues+0xd8/0x360
[ 144.405564] [<ffffff800813a330>] hrtimer_interrupt+0xa8/0x1e0
[ 144.411299] [<ffffff8008bfe798>] tegra210_timer_isr+0x38/0x48
[ 144.417034] [<ffffff8008122508>] __handle_irq_event_percpu+0x68/0x288
[ 144.423460] [<ffffff8008122750>] handle_irq_event_percpu+0x28/0x60
[ 144.429626] [<ffffff80081227d8>] handle_irq_event+0x50/0x80
[ 144.435187] [<ffffff80081265a0>] handle_fasteoi_irq+0xc8/0x1b8
[ 144.441006] [<ffffff80081214f4>] generic_handle_irq+0x34/0x50
[ 144.446739] [<ffffff8008121bd8>] __handle_domain_irq+0x68/0xc0
[ 144.452559] [<ffffff8008080d44>] gic_handle_irq+0x5c/0xb0
[ 144.457944] [<ffffff8008082c28>] el1_irq+0xe8/0x194
[ 144.462813] [<ffffff8008ba4ae0>] cpuidle_enter_state+0xb8/0x380
[ 144.468720] [<ffffff8008ba4e1c>] cpuidle_enter+0x34/0x48
[ 144.474020] [<ffffff8008111cc4>] call_cpuidle+0x44/0x70
[ 144.479233] [<ffffff8008112040>] cpu_startup_entry+0x1b0/0x200
[ 144.485055] [<ffffff8008092ce8>] secondary_start_kernel+0x190/0x1f8
[ 144.491307] [<00000000841621a4>] 0x841621a4
[ 144.495483] SMP: stopping secondary CPUs
[ 145.581489] SMP: failed to stop secondary CPUs 0,3
[ 145.586274] Kernel Offset: disabled
[ 145.589755] Memory Limit: none
[ 145.600768] Rebooting in 5 seconds…
[ 150.604725] SMP: stopping secondary CPUs
[ 151.691337] SMP: failed to stop secondary CPUs 0,3

This camera should be work after first run up system?

Hi @mateusz ,

Very strange phenomenon, do you have other working cameras? If you have other working imx219, it may be that the camera is damaged.

Continue to debug:
Please try this command and send us the running result and dmesg log:
v4l2-ctl --set-fmt-video=width=3264,height=2464,pixelformat=RG10 --stream-mmap --set-ctrl=sensor_mode=0 --stream-count=100 -d /dev/video0

Thank yor for reply,

I tried your command but it has some error, because terminal receive that: “unknown arguments: –set-fmt-video=width=3264,height=2464,pixelformat=RG10 –stream-mmap –set-ctrl=sensor_mode=0 –stream-count=100”

Hi @mateusz ,

It looks like the forum converted characters incorrectly.

I put the test command into the txt text and uploaded it as an attachment.

It seems that there is a problem uploading as an attachment, please delete this strange character manually.

Thank you for the exact command. I tried to use it, then terminal didn’t show anything, but on UART was continuous show:
[ 544.267566] vi 54080000.vi: tegra_channel_error_status:error 24002 frame 0
[ 544.314819] vi 54080000.vi: tegra_channel_error_status:error 4000 frame 1
[ 544.362028] vi 54080000.vi: tegra_channel_error_status:error 4000 frame 2
[ 544.409220] vi 54080000.vi: tegra_channel_error_status:error 4000 frame 3
[ 544.456420] vi 54080000.vi: tegra_channel_error_status:error 4000 frame 4
[ 544.503624] vi 54080000.vi: tegra_channel_error_status:error 4000 frame 5
[ 544.550823] vi 54080000.vi: tegra_channel_error_status:error 4000 frame 6
[ 544.598014] vi 54080000.vi: tegra_channel_error_status:error 4000 frame 7
[ 544.645139] vi 54080000.vi: tegra_channel_error_status:error 4000 frame 8
[ 544.692426] vi 54080000.vi: tegra_channel_error_status:error 4000 frame 9
[ 544.739635] vi 54080000.vi: tegra_channel_error_status:error 4000 frame 10
.
,
.
It was displayed until used ctrl+C in Jetson terminal.

Hi @mateusz ,

Can you plug the sensor again? As shown in the picture:

If it still doesn’t work, your camera may be damaged, and I will notify our sales staff to contact you.

Hello Wong

Unfortunately after reconnect camera problem is still active.
Thank you for leading me in debugging. I will contact my supplier about the complaint.

Best regards,
Mateusz

Hi @mateusz ,

Is there any progress? Have you got the new camera module?

I sent the camera to complain and I haven’t had any information yet. I will update this topic when I receive a camera.