Just received an ESP32 UNO board from RobotShop. Loaded new libraries. Tried to run ArduCAM_ESP32_Capture example and received an SPI error when I ran the example. Checked the FAQs and the memorysaver.h file is set for the OV2640 camera as specified by Robotshop. I also verified that the SPI initialize section was in the example per the FAQs. Still getting SPI error. New to this board, so I could use a little help. Thanks


Please make sure the camera is plugged in and the board is selected correctly, then refer to this link to operate.

If SPI error still exists, please send us your complete operation steps video, and we will try our best to help you.

I am using the Arducam ESP32 board. I camera is glued to the board, so I can’t verify the connection to the board. I added a location number to the SPI error messages to locate the exact location of the error in the code. I have attached screen captures of the serial window and the section of the code where the failure is occurring. I have also attached a picture of the board. Code compiles without any errors.

I am very familiar with using this type of camera with WROOM versions of the ESP family and have not had this problem with my other projects.Screenshot 1


You select the wrong board, your board modle is


Please refer to this link to reoperation.