Arducam driver imx 230

Arducam driver. Cannot stat. Not found
Using Kernal 5.10.60
Tech support says not the one the use
They use 5.10
How to get specific version for raspberry pi 4 b

Hi Pimark

5.10.60 is not in the pre-compiled version we provide.
You can refer to chapter 2.2. The second way-Build from the kernel headers in this document to compile the kernel driver:

The second way-Build from the kernel headers

Yes. So I use the info in 2.2 to make the camera work with 5.10.60?

Yes, according to the operation in the document, you can achieve 5.10.60 to make the camera work

That is exactly what I am trying to do with no luck
After. Promted with a Y/n after 2.2.1. it just says abort

After 2.2.2
modeprobe: FATAL: Module arducam not found in directory /lib/modules/5.10.60-v7l+

Hi @Pimark

May I ask where did you report the error for the first time?
Can you share your terminal output?


2.2.2

First reported to a support email address givin from kernal

2.2.1

Can you try copying one by one instead of copying together?


Enter one by one got me way further. All seemed good. But
When I try to access camera I get this

Can you provide dmesg logs and the content of /boot/config.txt?


Still not seeing the. Camera

It looks like you did not manually edit the /boot/config.txt file


Tip: You need to reboot after editing /boot/config.txt

I rebooted and it now works! Thanks so much
I’ve learned a valuable lesson on copying and pasting. And how to get this driver installed. You dabomb .com(:

Glad to hear that your problem has been solved.
If copying one of the multiple commands takes a long time to execute and it also receives keyboard input, then this problem will occur.
I think we should add more hints to the document.