Arducam 8MP UVC USB camera not working on Raspberry pi 4B

1.Which seller did you purchase the product(s) from?
robotshop ,
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Raspberry Pi 4B
4.Which instruction are you following?
5.Has your product ever worked properly?
the camera is working with laptops fine, but on the raspberry not yet
6.What problems are you experiencing?
Can’t connect an arducam usb camera module to my raspberry pi model 4B

the camera is working with laptops fine, and on the raspberry pi other camera connected with USB is working.
7.What attempts at troubleshooting have you already made?
8.How would you like us to help you?
Help me to troubleshoot the device.


Has your problem been solved? At present, I do not have the hardware version you purchased. Tested according to the version in my current hands, and did not find the problem you mentioned.
You can send an email to [email protected], and we will send you the new version of the firmware.


No, the Raspberry still does not recognize the camera device.

I tested the USB ports, all of them are working. It’s not a power supply issue. I tested it with another camera device (it’s a Microsoft webcam), and there was no problem.

Also the Arducam device works with computers without problem. However the Raspberry shows no connection when the camera is plugged in to USB port, and no video device is created.


Have you tried to reinstall the Raspberry Pi system for testing?

You try it.