Arducam 8MP Pan Tilt Zoom PTZ Camera with Base for Raspberry Pi 4/3B+/3

Order #100009125 (placed on June 17, 2020 4:52:12 AM CST)

I received my pan tilt zoom camera with pan tilt platform base

I have confirmed camera is working with rpi 3b

however I am unable to see the i2c access for zoom and focus.

I have tested the i2c interface with a rtc clock and it shows up with address 68.

Please advise




setup photos still no i2c

sda scl


rpi conn sda scl gnd


rpi conn 5v5v

raspistill cam pic


cable to camcable cam

Its a little hard to see in my RPI picture, but it looks like you are wired up right.

Have you tried running the example python code?

Although my setup has a different color scheme for the wire-harness, it looks to me like you wired it up right. Have you tried the example python code?


i2cdetect -y 1 with a rtc clock

real time clock connected

vcgencmd get_camera
supported=1 detected=1

git clone
Cloning into ‘PTZ-Camera-Controller’…
remote: Enumerating objects: 49, done.
remote: Total 49 (delta 0), reused 0 (delta 0), pack-reused 49
Unpacking objects: 100% (49/49), done.

Traceback (most recent call last):
File “”, line 26, in <module>
import cv2 #sudo apt-get install python-opencv
ModuleNotFoundError: No module named ‘cv2’


sudo apt install python-opencv

Traceback (most recent call last):
File “”, line 227, in <module>
File “”, line 219, in main
File “/usr/lib/python2.7/curses/”, line 43, in wrapper
return func(stdscr, *args, **kwds)
File “”, line 204, in draw_menu
File “”, line 82, in RenderMiddleText
focus_value = “Focus : {}”.format(focuser.get(Focuser.OPT_FOCUS))[:width-1]
File “/home/pi/Downloads/PTZ-Camera-Controller/pyCode/”, line 120, in get
File “/home/pi/Downloads/PTZ-Camera-Controller/pyCode/”, line 69, in waitingForFree
while self.isBusy() and count < (5 / 0.01):
File “/home/pi/Downloads/PTZ-Camera-Controller/pyCode/”, line 65, in isBusy
return,self.BUSY_REG_ADDR) != 0
File “/home/pi/Downloads/PTZ-Camera-Controller/pyCode/”, line 56, in read
value = self.bus.read_word_data(chip_addr,reg_addr)
IOError: [Errno 121] Remote I/O error


rpi gnd and 5v pins

vom reading from pins

please advise if additional information is needed.



Sorry for my late reply.We are very sorry that there is something wrong with

our website and we ignored your question.

For the PTZ controller board. If you have connected the

SDA SCL VCC and GND signal, it still does not detect the i2c address.

It seems the controller base board is defective. Please contact our [email protected]

for replacement.




thank you for the reply.

do I need an rma number or equivalent when I contact [email protected] ?



I received replacement controller board from arducam.

Swapped out the original board for the replacement board.

Now ptz camera is working with sample python code. Focus and zoom are working and

the the base with pan/tilt sensors is also working.


Thank you for the support.