Arducam 5MP SPI Cam Initialization Error

  1. Where did you get the camera module(s)?
    → Arducam 5MP SPI Camera

  2. Model number of the product(s)?
    → I don’t know where the model number is.
    The product says
    Front: Mini-5MP-Plus
    Back: UC-367, Rev.E

  3. What hardware/platform were you working on?
    → Raspberry Pi PICO W

  4. Instructions you have followed. (link/manual/etc.)
    GitHub - ArduCAM/PICO_SPI_CAM
    I tested the following methods using Python.

  5. Problems you were having?
    → The first connection worked without any problems.
    About 2 hours after the first connection, the screen did not work during the test by changing the
    resolution, and the following message occurred when the PICO was shut down and reconnected,
    and the camera did not initialize after that.

Traceback (most recent call last):
File “”, line 18, in
File “”, line 201, in Camera_Detection
File “”, line 225, in rdSensorReg16_8
File “”, line 238, in iic_write
OSError: [Errno 19] No such device


  1. The dmesg log from your hardware?
    → None

  2. Troubleshooting attempts you’ve made?
    → I tried reconnecting and checking the lines, initializing the PICO board and trying to get it to
    work again, and deleting and reinstalling all libraries.

  3. What help do you need?
    → I would like to know how to get it working again. If it’s bad, I want to replace it with a good one.

Welcome to our community! Do you have extra cable line and another camera module?
As normal, if the camera is connect normal and the power is normal, it is impossible to broken only working about two hours. I suggest you change extra cable line to retry, if the phenomenon is still exist, maybe the issue is move on the camera.