Arducam 2MP mini plus and MLX90614

1.Which seller did you purchase the product(s) from?
Changing wiring, adding and removing the temperature sensors, using a different camera module, and various other smaller code changes I’ve found recommended by a Google search.
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Adafruit Feather Huzzah
4.Which instruction are you following?
Example from Arduino IDE
5.Has your product ever worked properly?
6.What problems are you experiencing?
Is it possible to have the Arducam module and another sensor hooked up to the same microcontroller? I have the Arducam working on its own with an Adafruit Feather Huzzah, but when I try to connect MLX90614 temperature sensors to the same microcontroller, the arducam no longer works, with a message that indicates there’s an SPI error. I am using SDA/SCL pins to connect both the Arducam and the temperature sensors. The camera no longer works even if I have just wired the temperature sensors to the microcontroller but haven’t yet programmed them. The camera works again when I remove the connections to the temperature sensors.
7.What attempts at troubleshooting have you already made?

8.How would you like us to help you?
Do you have an example of using both the MLX90614 and an Arducam with the same microcontroller? Or if not, do you have an example of how to connect another sensor to the same microcontroller the Arducam is using? Both a connection diagram and an example application to capture an image.


Phenomenally, the SPI error is caused by the temperature sensor. But since your temperature sensor uses SDA/SCL, it usually does not cause SPI errors. It is possible that the power supply is insufficient after you plug in the temperature sensor, causing the microcontroller to work abnormally.
Our current example is just to ensure that the camera can work normally, there is no example of connecting other devices to work together.

Haha, and that was the problem, dunno why I didn’t think of that! Once I hooked up the camera to an external breadboard power supply instead of the microcontroller, everything worked fine. Thanks for your help!

You are welcome!

If you have any questions, feel free to contact us.