Arducam 12MP*2 Synchronized Stereo Camera Bundle with RPi 4 camera not detected

Please be patient – I am new to RPi, although I have a lot of experience with Arduino. Just trying to get started with a brand 12 MP new sync stereo camera bundle and a new RPi 4, imaged with the latest 32-bit Raspberry Pi OS.

Followed the instructions in the tutorial video to connect the hardware. I should say – the video was hard to follow – too much text, and poor camera angles make it very hard to see proper flat cable orientations. After several attempts, I am confident I have the cables oriented correctly. I have followed the steps at Camarray – Arducam 12MP Synchronized Stereo Camera Bundle Kit - Arducam that apply to my situation as far as I can tell. Specifically, I followed these instructions:

If you are running the latest version of Raspberry Pi OS. (January 28th,2022 or later releases, Debian version:11(Bullseye)). You need to update the config file and use libcamera apps.

  • For Raspberry Bullseye users running on Pi 4, please do the following:

sudo nano /boot/config.txt
Find the line: camera_auto_detect=1, update it to:
camera_auto_detect=0
dtoverlay=imx477
Save and reboot.

Camera does not appear in Raspberry Pi Configuration > Interfaces. vcgencmd get_camera returns supported=0 detected=0, libcamera interfaces=0. I enabled I2C, then rebooted as some posters suggested, but that did not change anything. I first attempted all of this with the latest 64 bit RPi OS, and when that did not work, I went through the same steps with the 32 bit OS, but the behavior seems the same.

The Raspberry Pi configuration interface does not match what I am seeing in your tutorial (Interfaces > Camera does not appear). The other instructions in the tutorial for “Raspberry Pi Compute Module 3/4” and “Basic Usage on the Legacy System” seem not to apply to my configuration.

Here are photos of my connections:



What steps can I take from here?

Just to clarify, the RPi model I am using is Raspberry Pi 4 Model B Quad Core 64 Bit WiFi Bluetooth (8GB).

hi, @lloydtravissmith

Sorry, there are still many problems with our video, we will improve the instructional video as soon as possible.

What version of Raspberry Pi system are you currently using? You can use the following command to check the system version you are currently using:

cat /etc/os-release

We recommend the Bullseye system.

PRETTY_Name=“Raspbian GNU/Linux 11 (bullseye)”

I revisited this today while waiting for a response from the forum, and I discovered that even though I do not have the option to enable the camera in Raspberry Pi Configuration > Interfaces, I do have the option to run raspi-config and under Interfaces there is an option entitled Legacy Camera Enable /disable legacy camera support. After enabling this option and rebooting, the camera is found and I can see the feed by using raspistill -t 0.

I have the impression that the operating system has evolved since you posted your documentation, and you need to go back and incorporate steps that make sense in the context of the current RPi 4 product and OS.

Hi,
Thanks for your great advice, We will update our video demo based on latest system version.

Just a couple of other notes, in case these prove significant to other users. I had tried the recommended steps for RPi 4:

sudo nano /boot/config.txt
Find the line: camera_auto_detect=1, update it to:
camera_auto_detect=0
dtoverlay=imx477
Save and reboot.

But just befire I got things working, I had set camera_auto_detect back to 1 and I commented out (#) #dtoverlay=imx477.

Now that I look at the config.txt, I see that in the section [pi4] there is an entry:
dtoverlay=vc4-fkms-v3d. In the main body under the comment “# Automatically load overlays for detected cameras” there is an entry “start_x=1” just before “#dtoverlay=imx477”.

I am not certain how many of these entries are obvious, or how many were created by the OS after I enabled camera_auto_detect.

After getting the camera to work with raspistill by using Legacy Camera Enable, I thought I was well on my way to accessing the camera through Python using PiCamera(), but that was not true. I am extremely disappointed now to see that the Stereo Camera bundle does not work with Python at all. Apparently the only way to use this camera bundle with Raspberry Pi is in legacy camera mode and using the deprecated raspistill and raspivid commands. I believe that I had it working with the same limitations in Bullseye, and I thought I might be able to get around the limitations by reverting to Raspberry Pi OS (Legacy), aka Buster, but I face the same problems in this configuration. If the camera bundle does not work on Bullseye or with Python, then it is not a suitable camera bundle for use with RaspberryPi at all. Am I missing something?

Hi,
Arducam new 12MP*2 Synchronized Stereo Camera Bundle does not support on legacy version camera framework. It just support libcamera framework on bullseye system.

If you review the posts I have made in this thread, you will see that I was not able to get the camera working by following the instruction posted on your site. The only way I was able to get the OS to recognize the cameras was by enabling legacy camera support. With legacy support enabled, I was able to preview the camera feed in real time with raspistill -t 0 and raspivid -t 0. Without enabling Legacy Camera Support, the camera was not recognized. I followed these instructions

If you are running the latest version of Raspberry Pi OS. (January 28th,2022 or later releases, Debian version:11(Bullseye)). You need to update the config file and use libcamera apps.

  • For Raspberry Bullseye users running on Pi 4, please do the following:

sudo nano /boot/config.txt
Find the line: camera_auto_detect=1, update it to:
camera_auto_detect=0
dtoverlay=imx477
Save and reboot.

After following the above instructions, the entry “Camera” did not appear in Raspberry Pi Configuration > Interfaces. vcgencmd get_camera returned supported=0 detected=0, libcamera interfaces=0. I enabled I2C, then rebooted as some posters suggested, but that did not change anything. I first attempted all of this with the latest 64 bit RPi OS, and when that did not work, I went through the same steps with the 32 bit OS, but the behavior seems the same.

Now I am back to the 64 bit OS and considering changing to a different camera, since the documentation on how to get the camera working is inconsistent with the current operating system.

If you assert that the Arducam 12MP*2 Synchronized Stereo Camera Bundle is compatible with Raspberry Pi4 B with Bullseye installed, it would be extremely important to post up to date documentation describing how to get the camera working with the latest OS and the Raspberry Pi 4 B hardware and the Bullseye OS.

  1. Where did you get the camera module(s)?
  • Purchased from UCTRONICS
  1. Model number of the product(s).
  • Arducam 12MP*2 Synchronized Stereo Camera Bundle Kit for Raspberry Pi, Two 12.3MP IMX477 Camera Modules with CS Lens and Camarray Stereo Camera HAT
    SKU: B0265R
  1. What hardware/platform were you working on?
  • Raspberry Pi 4 b running Rasberry PI OS Bullseye 64 bit (tested also with 32 bit)
  1. Instructions you have followed. (link/manual/etc.)
  1. Problems you were having.
    The camera is not recognized.
  • [email protected]:~ $ vcgencmd get_camera
  • supported=0 detected=0, libcamera interfaces=0
  1. The dmesg log from your hardware.
  • see my next reply (too long for this post)
  1. Troubleshooting attempts you’ve made.
  • Tried the recommended steps from above Arducam docs link on both 32 bit and 64 bit Bullseye OS.
  • vcgencmd get_camera returns supported=0 detected=0 libcamera interfaces=0
  • libcamera-hello returns

Made X/EGL preview window [0:01:49.178002923] [1479] INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3544-22656360 ERROR: *** no cameras available ***

  • Verified that the camera is connected correctly by using Enable Legacy Camera Support, running vcgencmd get_camera and verifying that it returned supported=1 detected=1, and then running raspistill -t 0 and raspivid -t 0, which both produce the expected image/video.
  1. What help do you need?
  • Please review the information I have provided and explain what configuration steps need to be taken for Raspberry Pi 4 model B running Bullseye OS to allow vcgencmd get_camera to recognize the camera/hat and how to verify it is working.
  1. dmesg log

I don’t know if it is helpful, but on another forum thread I see that there is some discussion about which I2C bus the camera is connected to, and perhaps the camera is on a different bus than the standard camera support software would assume. I checked with and without the stereo camera hat plugged in, and as poster c2h6 mentioned in his January 16 post, the camera hat appears to be on Bus 0x0A (10). I ran i2cdetect -y 10 with and without the camera hat, and I can see the same values on Bus 10 when the hat is connected, and they disappear when the hat is disconnected:

WITH THE HAT CONNECTED:
[email protected]:~ $ i2cdetect -l
i2c-20 i2c Broadcom STB : I2C adapter
i2c-10 i2c i2c-22-mux (chan_id 1) I2C adapter
i2c-1 i2c bcm2835 ([email protected]) I2C adapter
i2c-21 i2c Broadcom STB : I2C adapter
i2c-0 i2c i2c-22-mux (chan_id 0) I2C adapter
i2c-22 i2c bcm2835 ([email protected]) I2C adapter
[email protected]:~ $ i2cdetect -y 10
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: – – – – 24 – – – – – – – – – – –
30: – – – – – – – – – – – – – – – –
40: – – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: – – – – 64 – – – – – – – – – – –
70: – – – – – – – –
[email protected]:~ $

WITH THE HAT DISCONNECTED:
[email protected]:~ $ i2cdetect -l
i2c-20 i2c Broadcom STB : I2C adapter
i2c-10 i2c i2c-22-mux (chan_id 1) I2C adapter
i2c-1 i2c bcm2835 ([email protected]) I2C adapter
i2c-21 i2c Broadcom STB : I2C adapter
i2c-0 i2c i2c-22-mux (chan_id 0) I2C adapter
i2c-22 i2c bcm2835 ([email protected]) I2C adapter
[email protected]:~ $ i2cdetect -y 10
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: – – – – – – – – – – – – – – – –
30: – – – – – – – – – – – – – – – –
40: – – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: – – – – – – – – – – – – – – – –
70: – – – – – – – –

Hello,

This camera can be used on Bullseye system. You just need to config it and run libcamera apps. From the above information you mentioned, I think you don’t need to enable legacy. You can run raspi-config to disable the legacy and execute the config file(dtoverlay=imx477 and camera_auto_detect=0). Then reboot.
The Bullseye system doesn’t use vcgencmd get_camera to detect cameras. You can input ls /dev/video* to check if there is /dev/video0. If it exists, the camera has been detected and you can use libcamera apps to access it.
Looking forward to your reply.

I have set these parameters in the config.

ls /dev/video* yields:

/dev/video10 /dev/video13 /dev/video16 /dev/video21 /dev/video31
/dev/video11 /dev/video14 /dev/video18 /dev/video22
/dev/video12 /dev/video15 /dev/video20 /dev/video23

libcamera-hello yields:

Made X/EGL preview window
[4:32:54.231020858] [2070] INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3544-22656360
ERROR: *** no cameras available ***

All of the responses I have received here seem quite confident that the Arducam 12MP*2 Synchronized Stereo Camera Bundle will work with Raspberry Pi 4 model B using the libcamera-apps, but I am getting nowhere with this. Any advice?

Hi,
Don’t worry. Maybe we can help you by remote assistant. Please contact our [email protected] for detail steps.

I wrote to [email protected] on the morning of June 29 requesting support as you recommended, but I have not yet received a response.

Sorry to hear that.
Please tell me your email address. our sales will check it again.

[email protected]hsolutions.com