8MP Sync Stereo HAT(Bundle Kit) with Rasp4 Problem

I just bought Arducam 8MP Sync Stereo Camera Bundle Kit 2 days ago to use with raspberry pi 4, and I’ve followed the instructions on https://www.arducam.com/docs/cameras-for-raspberry-pi/synchronized-stereo-camera-hat/opencv-and-depth-map-on-arducam-stereo-camera-hat-tutorial/?fbclid=IwAR27qJs_rImaRE_oSnaGXfqGRPLXD45yipzFNJydiIcmWLaLKOnp9y8Ig0s

Raspbian version: May 2020 (Kernel 4.19)

First Problem, I try to run this file “1_test.py”(from tutorial instruction above), and the command line said " Load Libarducam_mipicamera fail" After that, I changed the calling path to directory where the library isNow,I try to run “1_test.py” again, and I got an second error.Now, I have no any idea about this, and I just follow solution from others who have same error then I put this to config.txt (In red frame)I think it’s connected successfully with 8MP Sync Stereo HAT then I run “1_test.py” again, and I got third error say that “unexpected result”

What should I do next? or any part from above is wrong

I’ve try this stereo-HAT device with raspberry pi 4 and 3B, and I got same error

Any ideas on how to solve it would be welcomed

Thanks in advance.

Hi @Kavin ,

Please follow the steps in this document first, you can first use arducamstill to test the hardware. When you are sure there is no problem, run stereo_depth_demo

Thank you so much for your instruction

Now, I’ve follow all step refer to https://github.com/ArduCAM/MIPI_Camera/tree/master/RPI ,and I’ve try to run arducamstill and I got this"Init camera status = 4100 is shown" Is this a type of an error? I’ve change another cable and reconnect but I got the same “camera status = 4100”


Please attach me your hardware connection. It can’t detect the i2c address which seems the

hardware connection is abnormal.

andI’ve try with my rasp4B.

Thank for your reply. @bin


Hardware connection seems normal. Have you update the wiringPi library using the follow commads?

cd /tmp
wget https://project-downloads.drogon.net/wiringpi-latest.deb
sudo dpkg -i wiringpi-latest.deb

I’ve already done that, but I got the same result.


Very strange. Have you tried to change another ribbon cable?

Another way, you can remove the stereo hat firstly and test the camera separately.

We need to isolate the problem and check it.


Yes, I changed my ribbon to another one and connect them again, and can I test for single camera like this? after all, I’ve got same error



Don’t worry, if the hardware is defective, we will give you a replacement.

If the single camera, you should connect the camera A.


this code works normally with my single rasp camera module v2(IMX219).

I’ve try this code to run stereo camera A, and it can not run the camera.


Please run vcgencmd get_camera to detect the camera. If nomal, you will see the detected=1, supported =1.