64mp Quad Camera Hat Desynchronisation

  1. Where did you get the camera module(s)?
    Arducam preorder
  2. Model number of the product(s)?
    64MP Autofocus Quad-Camera Kit for Raspberry Pi
  3. What hardware/platform were you working on?
    Raspberry Pi 4B 4GB - Raspberry Pi OS
  4. Instructions you have followed. (link/manual/etc.)
    PDF guide for quad camera + libcamera guides from arducam site
  5. Problems you were having?
  6. The dmesg log from your hardware?
    [ 11.570086] arducam_64mp: loading out-of-tree module taints kernel.
    [ 11.583608] arducam_64mp 10-001a: Device found Arducam 64MP.
    [ 11.586992] arducam_64mp 10-001a: Consider updating driver arducam_64mp to match on endpoints
  7. Troubleshooting attempts you’ve made?
    I tried to reduce shutterspeed and iso settings, tried raw format, lowering the resolution
  8. What help do you need?
    as you can see in the attached pictures there is a desynchronisation/delay between 2 pair of cameras in the quadhat camera setup. I need all 4 to be synchronized in order to take pictures of moving objects/people but I can’t make it work as it should. How can I get it working while keeping high resolution?

1 Like

I hope this can be fixed. Docs clearly state cameras are in sync. :confused:

1 Like

The delay between 2 pair of cameras is just one frame. If you want to get a better result, please try high framerate mode.

Is this delay expected?

Is there a way to make the completely in sync at all frame rates?



The four camera use the same XCLK, so they are in sync. each time, the hat jut can process two image, so if the four camera, the hat should receive two times and stitch into a picture,so, it will exist one frame delay. the delay can’t be cancelled. If the frame rate is high, this delay can be ignored.
Feel free to let me know if you need more help.

Thanks. Is there a way to get a buffer and then sync all frames?

You are welcome. At present,there is no a better way.