64mp camera failing on preview call


I have a 64mp Hawkeye module securely connected to a pi 4 with up to date OS. I’ve worked through the quick start guide and I think all libraries and drivers are installed.

When I test with libcamera-still -t 5000 a preview screen appears but is blank, and the attached scrolls on terminal.

Can anyone help me troubleshoot?

May you post pictures of hardware connection?

Hi Dion, thanks for the reply

Pretty sure it isn’t the connection, as I’ve replaced and tested with a normal pi v2 camera and it works fine… same ribbon and connections to the board

  • the camera is detected when I run —list-cameras


Here is a photo of the camera ribbon connection, and the call that shows the module is being recognised, but then goes into an endless loop of timeout on preview mode.

I can’t get easily to the other end of the ribbon as it is inside a bigger build, but the connection is good, as I said, I’ve tested it with a Picamera v2 and a Picamera HQ and both work fine.

Any suggestions welcome!

Please run the command " dpkg -l | grep libcamera" and give us the output in the terminal.

I got the camera working somehow - not sure how, but maybe it was a driver issue. thanks anyway!