16MP camera *** no cameras available ***

Hi,
I using trying to connect the 16MP camera using arducam HAT along with raspberry pi 4.
While accessing camera modules it shows no camera available i followed instruction from arducam website:
https://docs.arducam.com/Raspberry-Pi-Camera/Native-camera/Quick-Start-Guide/

raspberry pi version:
PRETTY_NAME=“Raspbian GNU/Linux 11 (bullseye)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“11”
VERSION=“11 (bullseye)”
VERSION_CODENAME=bullseye
ID=raspbian
ID_LIKE=debian

while accessing camera using libcamera-still -t 5000 commend i got following error:
Made X/EGL preview window
[0:05:45.974724121] [2227] INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3897-c3c878a9
ERROR: *** no cameras available ***

used this command ibcamera-still --list-cameras to check whether camera is detected and it shows:
No cameras available!

In config.txt file it shows :
dtoverlay=w1-gpio
enable_uart=1
gpu_mem=128
dtoverlay=imx519

while using this commend dmesg | grep arducam it shows nothing.

Hi,
Please use the command dmesg | grep imx519 to check if the camera driver has been installed.

Hi. I have the same issue on pi xero2W, V11 Bullseye. Same no response to dmesg. Zero2W works with std 5mp camera. All instructions followed to install. Any further help appreciated. Thanks.

hi Dion,

i getting these messages;

dmesg | grep imx519

[ 11.995396] imx519 10-001a: failed to read chip id 519, with error -5
[ 11.997175] imx519: probe of 10-001a failed with error -5

I was getting the same issue. I bought the 16MP imx519 unit off amazon a few months ago and had libcamera working, but couldn’t get it working with picamera2. Today I tried revisiting the problem and was having some issues, so I tried started from scratch. Now, even after following the instructions on this page, I still got the “No cameras available!” message. And when I tried to check for the drivers by running dmesg | grep imx519 i got no output, even though the install script had said the drivers were properly installed.

Just when I was about to give up, I decided to check the boot/config.txt. I realized that down at the bottom where the dtoverlay was declared, the line was commented out. opened the file by running sudo your/path/to/boot/config.txt, uncommented the line, saved and voila. working camera. I’m guessing when they pushed the latest updates to the script, someone was messing with the dtoverlay and forgot to revert changes.

Hi,
Please print the content of config.txt by using the command cat /boot/config.txt.

Hi,
Thank you for your feedback.
Yes, sometimes customers do not remember to modify the config.txt file. I try to edit a troubleshooting page for them. I think it will be helpful.

Hi,
Please contact [email protected] for further help. :smiley: