16mp Autofocus IMX519 libcamera installation issue

Hi All,
I am using Arducam16mp Autofocus IMX519 with respberrypi4 8gb. I am getting errors and warnig after executing libcamera-hello.

Made X/EGL preview window
[0:48:41.411577784] [1396]  INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3729-5f595cca
[0:48:41.435673418] [1398]  WARN CameraSensorProperties camera_sensor_properties.cpp:174 No static properties available for 'imx519'
[0:48:41.435821586] [1398]  WARN CameraSensorProperties camera_sensor_properties.cpp:176 Please consider updating the camera sensor properties database
[0:48:41.488334714] [1398]  WARN RPI raspberrypi.cpp:1274 Mismatch between Unicam and CamHelper for embedded data usage!
[0:48:41.489260138] [1398] ERROR DelayedControls delayed_controls.cpp:87 Delay request for control id 0x009a090a but control is not exposed by device /dev/v4l-subdev0
[0:48:41.489707086] [1398]  INFO RPI raspberrypi.cpp:1398 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media3 and ISP device /dev/media0
[0:48:41.491104211] [1396]  INFO Camera camera.cpp:1029 configuring streams: (0) 2328x1748-YUV420
[0:48:41.491746037] [1398]  INFO RPI raspberrypi.cpp:763 Sensor: /base/soc/i2c0mux/[email protected]/[email protected] - Selected sensor format: 2328x1748-SRGGB10_1X10 - Selected unicam format: 2328x1748-pRAA

However I am able to capture images with the same warning and error as above, I don’t know why am I getting these warnings and error.
Can Someone please help…?

I have tried installing dependencies using following commands:

wget -O install_pivariety_pkgs.sh https://github.com/ArduCAM/Arducam-Pivariety-V4L2-Driver/releases/download/install_script/install_pivariety_pkgs.sh
chmod +x install_pivariety_pkgs.sh
./install_pivariety_pkgs.sh -p libcamera_dev
./install_pivariety_pkgs.sh -p libcamera_apps
./install_pivariety_pkgs.sh -p imx519_kernel_driver
  1. 1st error after executing ./install_pivariety_pkgs.sh -p libcamera_dev

Get:1 /home/pi/libcamera-dev-0.0.8-bullseye-armhf.deb libcamera-dev armhf 0.0.8 [914 kB]
(Reading database … 104153 files and directories currently installed.)
Preparing to unpack …/libcamera-dev-0.0.8-bullseye-armhf.deb …
Unpacking libcamera-dev (0.0.8) over (0.0.8) …
Setting up libcamera-dev (0.0.8) …
" W: Repository is broken: libcamera-dev:armhf (= 0.0.8) has no Size information"

  1. Second error after executing ./install_pivariety_pkgs.sh -p libcamera_dev

Get:1 /home/pi/libcamera-apps-0.0.8-bullseye-armhf.deb libcamera-apps armhf 0.0.8 [260 kB]
(Reading database … 104153 files and directories currently installed.)
Preparing to unpack …/libcamera-apps-0.0.8-bullseye-armhf.deb …
Unpacking libcamera-apps (0.0.8) over (0.0.8) …
Setting up libcamera-apps (0.0.8) …
"W: Repository is broken: libcamera-apps:armhf (= 0.0.8) has no Size information"

  1. No issue while executing ./install_pivariety_pkgs.sh -p imx519_kernel_driver

System related information
uname -a

Linux raspberrypi 5.15.32-v7l+ #1538 SMP Thu Mar 31 19:39:41 BST 2022 armv7l GNU/Linux

cat /etc/os-release

PRETTY_NAME=“Raspbian GNU/Linux 11 (bullseye)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“11”
VERSION=“11 (bullseye)”
VERSION_CODENAME=bullseye
ID=raspbian
ID_LIKE=debian
HOME_URL=“http://www.raspbian.org/

My config.txt looks something like this:

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# Automatically load overlays for detected cameras
camera_auto_detect=1

# Automatically load overlays for detected DSI displays
display_auto_detect=1

# Enable DRM VC4 V3D driver
dtoverlay=vc4-kms-v3d
max_framebuffers=2

# Disable compensation for displays with overscan
disable_overscan=1

[cm4]
# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.
otg_mode=1

[all]

[pi4]
# Run as fast as firmware / board allows
arm_boost=1

[all]
#camera_auto_detect=0
dtoverlay=imx519
gpu_mem=128
enable_uart=1
dtoverlay=disable-bt

@birendra

hi,I replied to you in the mail, you can communicate with me here, or we continue to keep in touch in the mail.

@Edward
Hi, I cannot find your reply in mail,we can contiue communicating here as other people are also facing this issue, it will help others too if issue resolved.
Could you please help me in resolving this issue…?
Thanks.

@birendra

Maybe I’m mistaken, I have someone with the same problem email me.

Don’t worry about your first two problems, they will not affect your use, of course, we will fix them later.

i need some message

ls /dev/video*
sudo dpkg -l | grep libcamera

Then use the following command to try to see if I can run through the camera
libcamera-still -t 0


@Edward I have got the above results.
ls /dev/video*

/dev/video0 /dev/video11 /dev/video14 /dev/video18 /dev/video22
/dev/video1 /dev/video12 /dev/video15 /dev/video20 /dev/video23
/dev/video10 /dev/video13 /dev/video16 /dev/video21 /dev/video31

sudo dpkg -l | grep libcamera

ii libcamera-apps 0.0.8 armhf libcamera-apps
ii libcamera-dev 0.0.8 armhf libcamera

libcamera-still -t 0

I would like to say that preview window is launching, I can run through the camera with following warnings and error.

[0:01:41.331468658] [1268]  INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3729-5f595cca
[0:01:41.356296607] [1277]  WARN CameraSensorProperties camera_sensor_properties.cpp:174 No static properties available for 'imx519'
[0:01:41.356354753] [1277]  WARN CameraSensorProperties camera_sensor_properties.cpp:176 Please consider updating the camera sensor properties database
[0:01:41.393196788] [1277]  WARN RPI raspberrypi.cpp:1274 Mismatch between Unicam and CamHelper for embedded data usage!
[0:01:41.393968250] [1277] ERROR DelayedControls delayed_controls.cpp:87 Delay request for control id 0x009a090a but control is not exposed by device /dev/v4l-subdev0
[0:01:41.394635641] [1277]  INFO RPI raspberrypi.cpp:1398 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media2 and ISP device /dev/media0
[0:01:41.395926794] [1268]  INFO Camera camera.cpp:1029 configuring streams: (0) 2328x1748-YUV420
[0:01:41.396453984] [1277]  INFO RPI raspberrypi.cpp:763 Sensor: /base/soc/i2c0mux/[email protected]/[email protected] - Selected sensor format: 2328x1748-SRGGB10_1X10 - Selected unicam format: 2328x1748-pRAA

@birendra

Strangely, the camera is recognized, but doesn’t seem to be activated.
try this
libcamera-still -t 5000 -n -o test.jpg

@Edward
libcamera-still -t 5000 -n -o test.jpg is capturing saving image:

@birendra

This proves that both libcamera and camera are fine.

Maybe there is something wrong with your monitor, you can take a picture of your monitor connection, if your monitor is too big, you need to adjust the configuration to 720P

@Edward
I’m using VNC server on rpi4 and Vnc viewer on my laptop.
I will try to adjust Vnc resolution to 720p.

@birendra

If you are connected by vnc, the preview may have problems, you need to give your device an output interface

@Edward, i can capture images and videos- no issue in these.
just getting error unusually.
It should work fine despite of these error.

@Edward Thank you for looking into this issue.

@birendra

These errors and warnings, we have checked, and will not have any impact on your use, we will optimize the code in this area later, I wish you a happy weekend

1 Like