12MP HQ Stereo Sync hat issue

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
ARDUCAM UC-512 rev C
3.Which Platform are you using the product(s) on?
Raspberry 4B
4.Which instruction are you following?
Arducam online documentation
5.Has your product ever worked properly?
Yes. it was able to preview/capture/save.
6.What problems are you experiencing?

After some usage, my board doesnt preview and get stuck in the cmd.

I have did some checking,

  1. It is still able to find sensor and open the camera.

  2. I have readjusted the cables/pins to ensure they are secure and correct

  3. I ran vcgencmd get_camera and is able to detect

Please let me know additional information required for anyone in the forum to assist me.

Thanks in advance!

7.What attempts at troubleshooting have you already made?
8.How would you like us to help you?
Troubleshoot steps

Thanks for your business. Don’t worry and I will try my best to help you.

Please attach me your hardware connection and your product’s image, I need to ensure your product’s details.

Feel free to let me know if you need more help.